CVE-2022-32212 Command injection in Node
Attackers can execute arbitrary OS commands via DNS rebinding due to insufficient IP validation in Node.js.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-32212?
CVE-2022-32212 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.
Which versions are affected by CVE-2022-32212?
2 open source packages ship an affected version, including node and node-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0 |
node-min Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0 |
Products include Debian Debian Linux, Fedoraproject Fedora, Nodejs Node.js, Siemens Sinec Ins.
How do I fix CVE-2022-32212?
Upgrade node to a fixed version for your release line: 14.14.1, 14.20.1, 16.12.1 or 16.17.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-32212 being exploited?
There is no known exploitation of CVE-2022-32212 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-10149, BIT-node-2022-32212, BIT-node-min-2022-32212, CLEANSTART-2026-DF66102, DEBIAN-CVE-2022-32212, GHSA-w95h-2gj2-x2p4 and 1 more.