# CVE-2022-32212: Command injection in Node

> Attackers can execute arbitrary OS commands via DNS rebinding due to insufficient IP validation in Node.js.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2022
- **Updated:** 30 Apr 2025
- **Also known as:** AZL-10149, BIT-node-2022-32212, BIT-node-min-2022-32212, CLEANSTART-2026-DF66102, DEBIAN-CVE-2022-32212, GHSA-w95h-2gj2-x2p4, UBUNTU-CVE-2022-32212

## What is CVE-2022-32212?

CVE-2022-32212 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-32212?

2 open source packages ship an affected version, including node and node-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0 |
| `node-min` | Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0 |

Products: Debian Debian Linux, Fedoraproject Fedora, Nodejs Node.js, Siemens Sinec Ins.

## How do I fix CVE-2022-32212?

Upgrade node to a fixed version for your release line: 14.14.1, 14.20.1, 16.12.1 or 16.17.1.

## Is CVE-2022-32212 being exploited?

There is no known exploitation of CVE-2022-32212 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32212 and fix it if it is affected.

What it is: CVE-2022-32212 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32212 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0
- node-min (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32212/ (Markdown: https://insights.sbomify.com/CVE-2022-32212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32212
- OSV: https://osv.dev/vulnerability/CVE-2022-32212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32212/
Summaries are generated and may contain mistakes; the official description above is the record.
