CVE-2022-32213 llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding
Attackers can exploit HTTP Request Smuggling in Node.js by manipulating Transfer-Encoding headers, bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-32213?
CVE-2022-32213 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly parse and validate Transfer-Encoding headers and can lead to HTTP Request Smuggling (HRS).
Weakness: CWE-444
Which versions are affected by CVE-2022-32213?
4 open source packages ship an affected version, including llhttp, node and node-min. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
llhttp npm | All versions | 6.0.7 |
llhttp npm | All versions | 6.0.7 |
node Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.9.1 |
node-min Bitnami | From 14.0.0 | 14.14.1, 14.20.1, 16.12.1, 16.17.1, 18.9.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Llhttp Llhttp, Nodejs Node.js, Siemens Sinec Ins, Stormshield Stormshield Management Center.
How do I fix CVE-2022-32213?
Upgrade llhttp to 6.0.7 or later.
Is CVE-2022-32213 being exploited?
There is no known exploitation of CVE-2022-32213 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-32213, AZL-10150, AZL-41051, BIT-node-2022-32213, BIT-node-min-2022-32213, CLEANSTART-2026-AZ56181 and 5 more.