CVE-2022-32214 llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields
Attackers can exploit HTTP request smuggling in Node.js by bypassing CRLF delimiters, potentially leading to cache poisoning or security bypasses.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-32214?
CVE-2022-32214 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).
Weakness: CWE-444
Which versions are affected by CVE-2022-32214?
4 open source packages ship an affected version, including llhttp, node and node-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
llhttp npm | All versions | 6.0.7 |
llhttp npm | All versions | 6.0.7 |
node Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |
node-min Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |
Products include Debian Debian Linux, Llhttp Llhttp, Nodejs Node.js, Stormshield Stormshield Management Center.
How do I fix CVE-2022-32214?
Upgrade llhttp to 6.0.7 or later.
Is CVE-2022-32214 being exploited?
There is no known exploitation of CVE-2022-32214 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-32214, AZL-10151, AZL-40893, BIT-node-2022-32214, BIT-node-min-2022-32214, CLEANSTART-2026-UU15697 and 4 more.