{"answers":{"affected":"4 open source packages ship an affected version, including llhttp, node and node-min. It affects 4 products.","exploited":"There is no known exploitation of CVE-2022-32214 in the wild and no public exploit code.","fix":"Upgrade llhttp to 6.0.7 or later.","what":"CVE-2022-32214 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-32214 and fix it if it is affected.\n\nWhat it is: CVE-2022-32214 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-32214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- llhttp (npm): affected all versions; fixed in 6.0.7\n- llhttp (npm): affected all versions; fixed in 6.0.7\n- node (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0\n- node-min (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32214/ (Markdown: https://insights.sbomify.com/CVE-2022-32214/index.md)","id":"CVE-2022-32214","markdown":"https://insights.sbomify.com/CVE-2022-32214/index.md","name":"CVE-2022-32214","record":{"aliases":["ALPINE-CVE-2022-32214","AZL-10151","AZL-40893","BIT-node-2022-32214","BIT-node-min-2022-32214","CLEANSTART-2026-UU15697","CLEANSTART-2026-XP35596","DEBIAN-CVE-2022-32214","GHSA-q5vx-44v4-gch4","UBUNTU-CVE-2022-32214"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP parser","requires_auth":"none","summary":"Attackers can exploit HTTP request smuggling in Node.js by bypassing CRLF delimiters, potentially leading to cache poisoning or security bypasses.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"llhttp","vendor":"llhttp"},{"product":"node.js","vendor":"nodejs"},{"product":"stormshield_management_center","vendor":"stormshield"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"The llhttp parser \u003cv14.20.1, \u003cv16.17.1 and \u003cv18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields","id":"CVE-2022-32214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","nodejs:node.js"],"type":"other","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"Other in Node","id":"CVE-2022-32215"},"packages":[{"ecosystem":"Bitnami","fixed":["14.14.1","14.20.0","16.12.1","16.16.0","18.5.0"],"introduced":["14.0.0","14.15.0","16.0.0","16.13.0","18.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2022-32214"},{"ecosystem":"Bitnami","fixed":["14.14.1","14.20.0","16.12.1","16.16.0","18.5.0"],"introduced":["14.0.0","14.15.0","16.0.0","16.13.0","18.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2022-32214"},{"ecosystem":"npm","fixed":["6.0.7"],"introduced":["0"],"last_affected":[],"package":"llhttp","purl":null,"source":"GHSA-q5vx-44v4-gch4"},{"ecosystem":"npm","fixed":["6.0.7"],"introduced":["0"],"last_affected":[],"package":"llhttp","purl":"pkg:npm/llhttp","source":"GHSA-q5vx-44v4-gch4"}],"prev":{"headline":"llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding","id":"CVE-2022-32213"},"products":["Node"],"published":"2022-07-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Attackers can exploit HTTP request smuggling in Node.js by bypassing CRLF delimiters, potentially leading to cache poisoning or security bypasses.","url":"https://insights.sbomify.com/CVE-2022-32214/"}