# CVE-2022-32214: llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields

> Attackers can exploit HTTP request smuggling in Node.js by bypassing CRLF delimiters, potentially leading to cache poisoning or security bypasses.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2022
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2022-32214, AZL-10151, AZL-40893, BIT-node-2022-32214, BIT-node-min-2022-32214, CLEANSTART-2026-UU15697, CLEANSTART-2026-XP35596, DEBIAN-CVE-2022-32214, GHSA-q5vx-44v4-gch4, UBUNTU-CVE-2022-32214

## What is CVE-2022-32214?

CVE-2022-32214 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2022-32214?

4 open source packages ship an affected version, including llhttp, node and node-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llhttp` | npm | All versions | 6.0.7 |
| `llhttp` | npm | All versions | 6.0.7 |
| `node` | Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |
| `node-min` | Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |

Products: Debian Debian Linux, Llhttp Llhttp, Nodejs Node.js, Stormshield Stormshield Management Center.

## How do I fix CVE-2022-32214?

Upgrade llhttp to 6.0.7 or later.

## Is CVE-2022-32214 being exploited?

There is no known exploitation of CVE-2022-32214 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32214 and fix it if it is affected.

What it is: CVE-2022-32214 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32214 in the wild and no public exploit code.

Affected packages and fixed versions:
- llhttp (npm): affected all versions; fixed in 6.0.7
- llhttp (npm): affected all versions; fixed in 6.0.7
- node (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0
- node-min (Bitnami): affected from 14.0.0; fixed in 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32214/ (Markdown: https://insights.sbomify.com/CVE-2022-32214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32214
- OSV: https://osv.dev/vulnerability/CVE-2022-32214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32214/
Summaries are generated and may contain mistakes; the official description above is the record.
