CVE-2022-32215 Other in Node
Attackers can exploit HTTP request smuggling in Node.js via malformed Transfer-Encoding headers, bypassing security controls and potentially accessing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-32215?
CVE-2022-32215 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly handle multi-line Transfer-Encoding headers. This can lead to HTTP Request Smuggling (HRS).
Weakness: CWE-444
Which versions are affected by CVE-2022-32215?
2 open source packages ship an affected version, including node and node-min. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |
node-min Bitnami | From 14.0.0 | 14.14.1, 14.20.0, 16.12.1, 16.16.0, 18.5.0 |
Products include Debian Debian Linux, Fedoraproject Fedora, Llhttp Llhttp, Nodejs Node.js, Siemens Sinec Ins, Stormshield Stormshield Management Center.
How do I fix CVE-2022-32215?
Upgrade node to a fixed version for your release line: 14.14.1, 14.20.0, 16.12.1 or 16.16.0.
Is CVE-2022-32215 being exploited?
There is no known exploitation of CVE-2022-32215 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-32215, AZL-10153, AZL-41446, BIT-node-2022-32215, BIT-node-min-2022-32215, CLEANSTART-2026-NF09722 and 4 more.