{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-32222 in the wild and no public exploit code.","fix":"Upgrade node to 18.5.0 or later.","what":"CVE-2022-32222 is a medium-severity vulnerability in Nodejs Node.js, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-32222 and fix it if it is affected.\n\nWhat it is: CVE-2022-32222 is a medium-severity vulnerability in Nodejs Node.js, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-32222 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 18.0.0; fixed in 18.5.0\n- node-min (Bitnami): affected from 18.0.0; fixed in 18.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32222/ (Markdown: https://insights.sbomify.com/CVE-2022-32222/index.md)","id":"CVE-2022-32222","markdown":"https://insights.sbomify.com/CVE-2022-32222/index.md","name":"CVE-2022-32222","record":{"aliases":["BIT-node-2022-32222","BIT-node-min-2022-32222","GHSA-fxfc-w6xq-5pp8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js runtime","requires_auth":"none","summary":"Node.js on Linux may load an insecure OpenSSL configuration file, potentially weakening cryptographic security for applications.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node.js","vendor":"nodejs"},{"product":"sinec_ins","vendor":"siemens"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"},{"id":"CWE-310","name":null}],"description":"A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Weak cryptography in Node","id":"CVE-2022-32222","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"weak_cryptography","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Other in Node","id":"CVE-2022-32223"},"packages":[{"ecosystem":"Bitnami","fixed":["18.5.0"],"introduced":["18.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2022-32222"},{"ecosystem":"Bitnami","fixed":["18.5.0"],"introduced":["18.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2022-32222"}],"prev":{"headline":"Use after free in https://github.com/curl/curl","id":"CVE-2022-32221"},"products":["Node"],"published":"2022-07-14","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Node.js on Linux may load an insecure OpenSSL configuration file, potentially weakening cryptographic security for applications.","url":"https://insights.sbomify.com/CVE-2022-32222/"}