{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.uima:uimaj-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-32287 in the wild and no public exploit code.","fix":"Upgrade org.apache.uima:uimaj-core to 3.3.1 or later.","what":"CVE-2022-32287 is a high-severity path traversal vulnerability in Apache UIMA, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-32287 and fix it if it is affected.\n\nWhat it is: CVE-2022-32287 is a high-severity path traversal vulnerability in Apache UIMA, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-32287 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 3.3.1\n- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 3.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32287/ (Markdown: https://insights.sbomify.com/CVE-2022-32287/index.md)","id":"CVE-2022-32287","markdown":"https://insights.sbomify.com/CVE-2022-32287/index.md","name":"CVE-2022-32287","record":{"aliases":["GHSA-xgqr-5wqw-9fpv","UBUNTU-CVE-2022-32287"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache UIMA library","requires_auth":"none","summary":"Attackers can create files outside the target directory via crafted PEAR archives, potentially leading to code execution in Apache UIMA.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"uimaj","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A relative path traversal vulnerability in a FileUtil class used by the PEAR management component of Apache UIMA allows an attacker to create files outside the designated target directory using carefully crafted ZIP entry names. This issue affects Apache UIMA Apache UIMA version 3.3.0 and prior versions. Note that PEAR files should never be installed into an UIMA installation from untrusted sources because PEAR archives are executable plugins that will be able to perform any actions with the same privileges as the host Java Virtual Machine.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-17","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-17T08:16:54Z","kind":"github_poc","ref":"https://github.com/shoucheng3/apache__uima-uimaj_CVE-2022-32287_3-3-0","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache UIMA prior to 3.3.1 has a path traversal vulnerability when extracting (PEAR) archives","id":"CVE-2022-32287","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-32288"},"packages":[{"ecosystem":"Maven","fixed":["3.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.uima:uimaj-core","purl":null,"source":"GHSA-xgqr-5wqw-9fpv"},{"ecosystem":"Maven","fixed":["3.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.uima:uimaj-core","purl":"pkg:maven/org.apache.uima/uimaj-core","source":"GHSA-xgqr-5wqw-9fpv"}],"prev":{"headline":"Cross-site scripting in Mendix SAML Module (Mendix 7 compatible)","id":"CVE-2022-32286"},"products":["Apache UIMA"],"published":"2022-11-03","related":[{"cvss_score":8.8,"headline":"Apache UIMA Java SDK Deserialization of Untrusted Data, Improper Input Validation vulnerability","id":"CVE-2023-39913","kev_date_added":null,"published":"2023-11-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-02","vendors":["Apache Software Foundation"]},"summary":"Attackers can create files outside the target directory via crafted PEAR archives, potentially leading to code execution in Apache UIMA.","url":"https://insights.sbomify.com/CVE-2022-32287/"}