# CVE-2022-32287: Apache UIMA prior to 3.3.1 has a path traversal vulnerability when extracting (PEAR) archives

> Attackers can create files outside the target directory via crafted PEAR archives, potentially leading to code execution in Apache UIMA.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2022
- **Updated:** 2 May 2025
- **Also known as:** GHSA-xgqr-5wqw-9fpv, UBUNTU-CVE-2022-32287

## What is CVE-2022-32287?

CVE-2022-32287 is a high-severity path traversal vulnerability in Apache UIMA, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A relative path traversal vulnerability in a FileUtil class used by the PEAR management component of Apache UIMA allows an attacker to create files outside the designated target directory using carefully crafted ZIP entry names. This issue affects Apache UIMA Apache UIMA version 3.3.0 and prior versions. Note that PEAR files should never be installed into an UIMA installation from untrusted sources because PEAR archives are executable plugins that will be able to perform any actions with the same privileges as the host Java Virtual Machine.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-32287?

2 open source packages ship an affected version, including org.apache.uima:uimaj-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.uima:uimaj-core` | Maven | All versions | 3.3.1 |
| `org.apache.uima:uimaj-core` | Maven | All versions | 3.3.1 |

Products: Apache Uimaj.

## How do I fix CVE-2022-32287?

Upgrade org.apache.uima:uimaj-core to 3.3.1 or later.

## Is CVE-2022-32287 being exploited?

There is no known exploitation of CVE-2022-32287 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/apache__uima-uimaj_CVE-2022-32287_3-3-0 (github_poc): https://github.com/shoucheng3/apache__uima-uimaj_CVE-2022-32287_3-3-0

## Other vulnerabilities in Apache UIMA

- [CVE-2023-39913](https://insights.sbomify.com/CVE-2023-39913/): Apache UIMA Java SDK Deserialization of Untrusted Data, Improper Input Validation vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32287 and fix it if it is affected.

What it is: CVE-2022-32287 is a high-severity path traversal vulnerability in Apache UIMA, published on 3 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32287 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 3.3.1
- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32287/ (Markdown: https://insights.sbomify.com/CVE-2022-32287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32287
- OSV: https://osv.dev/vulnerability/CVE-2022-32287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32287/
Summaries are generated and may contain mistakes; the official description above is the record.
