# CVE-2022-32427: Path traversal in n/a

> Authenticated attackers can exploit directory traversal in PrinterLogic Windows Client to escalate privileges or distribute malicious content.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3rq3-j32x-vjg4

## What is CVE-2022-32427?

CVE-2022-32427 is a high-severity path traversal vulnerability in n/a, published on 25 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PrinterLogic Windows Client through 25.0.0.676 allows attackers to execute directory traversal. Authenticated users with prior knowledge of the driver filename could exploit this to escalate privileges or distribute malicious content. This issue has been resolved in PrinterLogic Windows Client 25.0.0688 and all affected are advised to upgrade.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-32427?

It affects 1 product.


Products: Printerlogic Windows Client.

## How do I fix CVE-2022-32427?

No fix has been published for CVE-2022-32427 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-32427 being exploited?

There is no known exploitation of CVE-2022-32427 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32427 and fix it if it is affected.

What it is: CVE-2022-32427 is a high-severity path traversal vulnerability in n/a, published on 25 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32427 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32427/ (Markdown: https://insights.sbomify.com/CVE-2022-32427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32427
- OSV: https://osv.dev/vulnerability/CVE-2022-32427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32427/
Summaries are generated and may contain mistakes; the official description above is the record.
