{"answers":{"affected":"2 open source packages ship an affected version, including jmespath. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-32511 in the wild and no public exploit code.","fix":"Upgrade jmespath to 1.6.1 or later.","what":"CVE-2022-32511 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-32511 and fix it if it is affected.\n\nWhat it is: CVE-2022-32511 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-32511 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jmespath (RubyGems): affected all versions; fixed in 1.6.1\n- jmespath (RubyGems): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32511/ (Markdown: https://insights.sbomify.com/CVE-2022-32511/index.md)","id":"CVE-2022-32511","markdown":"https://insights.sbomify.com/CVE-2022-32511/index.md","name":"CVE-2022-32511","record":{"aliases":["DEBIAN-CVE-2022-32511","GHSA-5c5f-7vfq-3732","MINI-x9qh-fv6h-pj45","UBUNTU-CVE-2022-32511"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JMESPath library","requires_auth":"none","summary":"The Ruby JMESPath library uses unsafe JSON loading, potentially allowing attackers to execute arbitrary code via crafted input.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"jmespath","vendor":"jmespath"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"jmespath.rb (aka JMESPath for Ruby) before 1.6.1 uses JSON.load in a situation where JSON.parse is preferable.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JMESPath for Ruby uses unsafe JSON.load when safe JSON.parse is preferable","id":"CVE-2022-32511","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":5,"next":{"headline":"A CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability exists that could cause remote code executi","id":"CVE-2022-32512"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"jmespath","purl":null,"source":"GHSA-5c5f-7vfq-3732"},{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"jmespath","purl":"pkg:gem/jmespath","source":"GHSA-5c5f-7vfq-3732"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2022-32510"},"products":["n/a"],"published":"2022-06-06","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["n/a"]},"summary":"The Ruby JMESPath library uses unsafe JSON loading, potentially allowing attackers to execute arbitrary code via crafted input.","url":"https://insights.sbomify.com/CVE-2022-32511/"}