# CVE-2022-3255: Cross-site Scripting (XSS) - Reflected in pimcore/pimcore

> Reflected Cross-Site Scripting in Pimcore allows attackers to execute scripts in victim browsers, leading to account takeover and data manipulation.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2022
- **Updated:** 28 May 2025
- **Also known as:** GHSA-wqr6-57qm-hhr5

## What is CVE-2022-3255?

CVE-2022-3255 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 21 Sep 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can: Perform any action within the application that the user can perform. View any information that the user is able to view. Modify any information that the user is able to modify. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-3255?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.7 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.7 |

Products: Pimcore Pimcore.

## How do I fix CVE-2022-3255?

Upgrade pimcore/pimcore to 10.5.7 or later.

## Is CVE-2022-3255 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3255 exists.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3255 and fix it if it is affected.

What it is: CVE-2022-3255 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 21 Sep 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3255 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.7
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3255/ (Markdown: https://insights.sbomify.com/CVE-2022-3255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3255
- OSV: https://osv.dev/vulnerability/CVE-2022-3255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3255/
Summaries are generated and may contain mistakes; the official description above is the record.
