# CVE-2022-32563: Couchbase Sync Gateway admin credentials not verified when using X.509 client cert authentication

> Unauthenticated users can escalate privileges via Admin REST API when X.509 client-certificate authentication is configured, bypassing admin credential checks.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9266-j9v3-q4j5, PYSEC-2022-207

## What is CVE-2022-32563?

CVE-2022-32563 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Couchbase Sync Gateway 3.x before 3.0.2. Admin credentials are not verified when using X.509 client-certificate authentication from Sync Gateway to Couchbase Server. When Sync Gateway is configured to authenticate with Couchbase Server using X.509 client certificates, the admin credentials provided to the Admin REST API are ignored, resulting in privilege escalation for unauthenticated users. The Public REST API is not impacted by this issue. A workaround is to replace X.509 certificate based authentication with Username and Password authentication inside the bootstrap configuration.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-32563?

3 open source packages ship an affected version, including couchbase. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `couchbase` | PyPI | From 3.0.0 | 3.0.2 |
| `couchbase` | PyPI | From 3.0.0 | 3.0.2 |
| `couchbase` | PyPI | From 3.0.0 | 3.0.2 |

Products: Couchbase Sync Gateway.

## How do I fix CVE-2022-32563?

Upgrade couchbase to 3.0.2 or later.

## Is CVE-2022-32563 being exploited?

There is no known exploitation of CVE-2022-32563 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-9039](https://insights.sbomify.com/CVE-2019-9039/): SQL Injection in Couchbase Sync Gateway (critical 9.8)
- [CVE-2021-43963](https://insights.sbomify.com/CVE-2021-43963/): Information disclosure in n/a (high 8.1)
- [CVE-2025-52490](https://insights.sbomify.com/CVE-2025-52490/): Couchbase Sync Gateway shows cleartext passwords in redacted and unredacted output (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32563 and fix it if it is affected.

What it is: CVE-2022-32563 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32563 in the wild and no public exploit code.

Affected packages and fixed versions:
- couchbase (PyPI): affected from 3.0.0; fixed in 3.0.2
- couchbase (PyPI): affected from 3.0.0; fixed in 3.0.2
- couchbase (PyPI): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32563/ (Markdown: https://insights.sbomify.com/CVE-2022-32563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32563
- OSV: https://osv.dev/vulnerability/CVE-2022-32563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32563/
Summaries are generated and may contain mistakes; the official description above is the record.
