CVE-2022-3265 Cross-site scripting in GitLab

High 7.3 Published Updated

Stored XSS in GitLab label color settings allows attackers to execute arbitrary client-side actions on behalf of victims.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-3265?

CVE-2022-3265 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 9 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. It was possible to exploit a vulnerability in setting the labels colour feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-3265?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.3.5, 15.4.4, 15.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-3265?

Upgrade gitlab to a fixed version for your release line: 15.3.5, 15.4.4 or 15.5.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-3265 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3265 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3265, GHSA-qxr4-8jqx-8c2w, UBUNTU-CVE-2022-3265.

Is CVE-2022-3265 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free