{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-3276 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-3276 is a high-severity command injection vulnerability in puppetlabs-mysql, published on 7 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-3276 and fix it if it is affected.\n\nWhat it is: CVE-2022-3276 is a high-severity command injection vulnerability in puppetlabs-mysql, published on 7 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-3276 in the wild and no public exploit code.\n\nAffected product: puppetlabs-mysql. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3276/ (Markdown: https://insights.sbomify.com/CVE-2022-3276/index.md)","id":"CVE-2022-3276","markdown":"https://insights.sbomify.com/CVE-2022-3276/index.md","name":"CVE-2022-3276","record":{"aliases":["DEBIAN-CVE-2022-3276","GHSA-6wx8-c453-jp55","RHSA-2022:7238","UBUNTU-CVE-2022-3276"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Puppet MySQL module","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary commands if they control unsanitized input to the Puppetlabs-mysql module, requiring specific deployment conditions.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"puppet","cpe":[{"product":"puppetlabs-mysql","vendor":"puppet"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.","ecosystems":["Red Hat:openstack:13::el7","Red Hat:openstack:16.1::el8","Red Hat:openstack:16.2::el8","Red Hat:openstack:17.0::el9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppetlabs-mysql Command Injection","id":"CVE-2022-3276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"openstack-neutron uncontrolled resource consumption flaw","id":"CVE-2022-3277"},"packages":[{"ecosystem":"Red Hat:openstack:13::el7","fixed":["0:5.2.2-0.20180216012143.a5497b2.el7ost"],"introduced":["0"],"last_affected":[],"package":"puppet-mysql","purl":"pkg:rpm/redhat/puppet-mysql","source":"RHSA-2022:7238"},{"ecosystem":"Red Hat:openstack:16.1::el8","fixed":["0:10.4.1-2.20221019195006.95f9b98.el8ost"],"introduced":["0"],"last_affected":[],"package":"puppet-mysql","purl":"pkg:rpm/redhat/puppet-mysql","source":"RHSA-2022:7238"},{"ecosystem":"Red Hat:openstack:16.2::el8","fixed":["0:10.4.1-2.20221019195006.95f9b98.el8ost"],"introduced":["0"],"last_affected":[],"package":"puppet-mysql","purl":"pkg:rpm/redhat/puppet-mysql","source":"RHSA-2022:7238"},{"ecosystem":"Red Hat:openstack:17.0::el9","fixed":["0:10.6.1-0.20220614215045.937d044.el9ost"],"introduced":["0"],"last_affected":[],"package":"puppet-mysql","purl":"pkg:rpm/redhat/puppet-mysql","source":"RHSA-2022:7238"}],"prev":{"headline":"Puppetlabs-apt Command Injection","id":"CVE-2022-3275"},"products":["puppetlabs-mysql"],"published":"2022-10-07","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2015-7224","kev_date_added":null,"published":"2017-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Puppet"]},"summary":"Attackers can execute arbitrary commands if they control unsanitized input to the Puppetlabs-mysql module, requiring specific deployment conditions.","url":"https://insights.sbomify.com/CVE-2022-3276/"}