CVE-2022-3279 Denial of service in GitLab

Low 2.7 Published Updated

An attacker can cause a denial of service by triggering an unhandled exception in job log parsing, preventing access to logs.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3279?

CVE-2022-3279 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An unhandled exception in job log parsing in GitLab CE/EE affecting all versions prior to 15.2.5, 15.3 prior to 15.3.4, and 15.4 prior to 15.4.1 allows an attacker to prevent access to job logs

Weakness: CWE-755

Which versions are affected by CVE-2022-3279?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.2.5, 15.3.4, 15.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-3279?

Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-3279 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3279 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3279, GHSA-c246-wwgq-rr54, UBUNTU-CVE-2022-3279.

Is CVE-2022-3279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free