CVE-2022-3285 Security feature bypass in GitLab
An unauthorized attacker can bypass healthcheck endpoint allow lists to prevent access to GitLab, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3285?
CVE-2022-3285 is a medium-severity vulnerability in Gitlab Gitlab, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Bypass of healthcheck endpoint allow list affecting all versions from 12.0 prior to 15.2.5, 15.3 prior to 15.3.4, and 15.4 prior to 15.4.1 allows an unauthorized attacker to prevent access to GitLab
Which versions are affected by CVE-2022-3285?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.0.0 | 15.2.5, 15.3.4, 15.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3285?
Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.
Is CVE-2022-3285 being exploited?
There is no known exploitation of CVE-2022-3285 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3285, GHSA-gchc-78gm-5379, UBUNTU-CVE-2022-3285.