CVE-2022-3288 Business logic in GitLab
An attacker can manipulate GitLab pages by exploiting branch/tag name confusion, altering content where the default branch is expected.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-3288?
CVE-2022-3288 is a low-severity vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A branch/tag name confusion in GitLab CE/EE affecting all versions prior to 15.2.5, 15.3 prior to 15.3.4, and 15.4 prior to 15.4.1 allows an attacker to manipulate pages where the content of the default branch would be expected.
Weakness: CWE-471
Which versions are affected by CVE-2022-3288?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 15.2.5, 15.3.4, 15.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3288?
Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.
Is CVE-2022-3288 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3288 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3288, GHSA-q9g6-jf2g-r26w, UBUNTU-CVE-2022-3288.