CVE-2022-3291 Information disclosure in GitLab
Attackers can leak sensitive information from the cache due to improper serialization of sensitive data in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3291?
CVE-2022-3291 is a medium-severity vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Serialization of sensitive data in GitLab EE affecting all versions from 14.9 prior to 15.2.5, 15.3 prior to 15.3.4, and 15.4 prior to 15.4.1 can leak sensitive information via cache
Weakness: CWE-502
Which versions are affected by CVE-2022-3291?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.9.0 | 15.2.5, 15.3.4, 15.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3291?
Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.
Is CVE-2022-3291 being exploited?
There is no known exploitation of CVE-2022-3291 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3291, GHSA-hgr5-p9jr-23mm, UBUNTU-CVE-2022-3291.