# CVE-2022-33099: Memory corruption in n/a

> A heap-buffer overflow in Lua's error handling allows attackers to execute arbitrary code or cause denial of service via recursive errors.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALSA-2022:7329, AZL-10045, AZL-35032, AZL-41192, BIT-lua-2022-33099, DEBIAN-CVE-2022-33099, GHSA-39jx-jr53-979c, JLSEC-2026-561, OESA-2022-1764, RHSA-2022:7329, RLSA-2022:7329, UBUNTU-CVE-2022-33099, openSUSE-SU-2024:12167-1

## What is CVE-2022-33099?

CVE-2022-33099 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-33099?

1 open source package ship an affected version, including lua. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lua` | Bitnami | From 5.4.2 | 5.4.5 |
| `lua` | AlmaLinux:9 | All versions | 5.4.2-4.el9_0.3 |
| `lua-devel` | AlmaLinux:9 | All versions | 5.4.2-4.el9_0.3 |
| `lua-libs` | AlmaLinux:9 | All versions | 5.4.2-4.el9_0.3 |
| `lua` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-libs-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:5.4.2-4.el9_0.3 |
| `lua` | Red Hat:enterprise_linux:9::baseos | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debuginfo` | Red Hat:enterprise_linux:9::baseos | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debugsource` | Red Hat:enterprise_linux:9::baseos | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-libs` | Red Hat:enterprise_linux:9::baseos | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-libs-debuginfo` | Red Hat:enterprise_linux:9::baseos | All versions | 0:5.4.2-4.el9_0.3 |
| `lua` | Red Hat:enterprise_linux:9::crb | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-debugsource` | Red Hat:enterprise_linux:9::crb | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:5.4.2-4.el9_0.3 |
| `lua-libs-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:5.4.2-4.el9_0.3 |
| `lua` | Rocky Linux:9 | All versions | 0:5.4.2-4.el9_0.3 |

Products: Fedoraproject Fedora, Lua Lua.

## How do I fix CVE-2022-33099?

Upgrade lua to 5.4.5 or later.

## Is CVE-2022-33099 being exploited?

There is no known exploitation of CVE-2022-33099 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33099 and fix it if it is affected.

What it is: CVE-2022-33099 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33099 in the wild and no public exploit code.

Affected packages and fixed versions:
- lua (Bitnami): affected from 5.4.2; fixed in 5.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33099/ (Markdown: https://insights.sbomify.com/CVE-2022-33099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33099
- OSV: https://osv.dev/vulnerability/CVE-2022-33099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33099/
Summaries are generated and may contain mistakes; the official description above is the record.
