# CVE-2022-33127: Improper handling of double quotes in file name in Diffy in Windows environment

> Attackers can execute arbitrary commands on Windows systems by providing filenames with double quotes to the Diffy library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5ww9-9qp2-x524, UBUNTU-CVE-2022-33127

## What is CVE-2022-33127?

CVE-2022-33127 is a critical command injection vulnerability in n/a, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The function that calls the diff tool in Diffy 3.4.1 does not properly handle double quotes in a filename when run in a windows environment. This allows attackers to execute arbitrary commands via a crafted string.

## Which versions are affected by CVE-2022-33127?

2 open source packages ship an affected version, including diffy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `diffy` | RubyGems | All versions | 3.4.1 |
| `diffy` | RubyGems | All versions | 3.4.1 |

Products: Diffy Project Diffy.

## How do I fix CVE-2022-33127?

Upgrade diffy to 3.4.1 or later.

## Is CVE-2022-33127 being exploited?

There is no known exploitation of CVE-2022-33127 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33127 and fix it if it is affected.

What it is: CVE-2022-33127 is a critical command injection vulnerability in n/a, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33127 in the wild and no public exploit code.

Affected packages and fixed versions:
- diffy (RubyGems): affected all versions; fixed in 3.4.1
- diffy (RubyGems): affected all versions; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33127/ (Markdown: https://insights.sbomify.com/CVE-2022-33127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33127
- OSV: https://osv.dev/vulnerability/CVE-2022-33127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33127/
Summaries are generated and may contain mistakes; the official description above is the record.
