# CVE-2022-33140: Improper Neutralization of Command Elements in Shell User Group Provider

> Authenticated privileged users can execute arbitrary OS commands via ShellUserGroupProvider in Apache NiFi when this optional provider is enabled.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nifi-2022-33140, GHSA-77hf-23pq-2g7c

## What is CVE-2022-33140?

CVE-2022-33140 is a high-severity command injection vulnerability in Apache Nifi, published on 15 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The optional ShellUserGroupProvider in Apache NiFi 1.10.0 to 1.16.2 and Apache NiFi Registry 0.6.0 to 1.16.2 does not neutralize arguments for group resolution commands, allowing injection of operating system commands on Linux and macOS platforms. The ShellUserGroupProvider is not included in the default configuration. Command injection requires ShellUserGroupProvider to be one of the enabled User Group Providers in the Authorizers configuration. Command injection also requires an authenticated user with elevated privileges. Apache NiFi requires an authenticated user with authorization to modify access policies in order to execute the command. Apache NiFi Registry requires an authenticated user with authorization to read user groups in order to execute the command. The resolution removes command formatting based on user-provided arguments.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-33140?

5 open source packages ship an affected version, including org.apache.nifi.registry:nifi-registry-core, nifi and org.apache.nifi:nifi. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi.registry:nifi-registry-core` | Maven | From 0.6.0 | 1.16.3 |
| `org.apache.nifi.registry:nifi-registry-core` | Maven | From 0.6.0 | 1.16.3 |
| `nifi` | Bitnami | From 1.10.0 to 1.16.2 | None |
| `org.apache.nifi:nifi` | Maven | From 1.10.0 | 1.16.3 |
| `org.apache.nifi:nifi` | Maven | From 1.10.0 | 1.16.3 |

Products: Apache Nifi, Apache Nifi Registry.

## How do I fix CVE-2022-33140?

Upgrade org.apache.nifi.registry:nifi-registry-core to 1.16.3 or later.

## Is CVE-2022-33140 being exploited?

There is no known exploitation of CVE-2022-33140 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/apache__nifi_CVE-2022-33140_1-16-22 (github_poc): https://github.com/shoucheng3/apache__nifi_CVE-2022-33140_1-16-22

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33140 and fix it if it is affected.

What it is: CVE-2022-33140 is a high-severity command injection vulnerability in Apache Nifi, published on 15 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33140 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi.registry:nifi-registry-core (Maven): affected from 0.6.0; fixed in 1.16.3
- org.apache.nifi.registry:nifi-registry-core (Maven): affected from 0.6.0; fixed in 1.16.3
- nifi (Bitnami): affected from 1.10.0 up to 1.16.2; no fix listed
- org.apache.nifi:nifi (Maven): affected from 1.10.0; fixed in 1.16.3
- org.apache.nifi:nifi (Maven): affected from 1.10.0; fixed in 1.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33140/ (Markdown: https://insights.sbomify.com/CVE-2022-33140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33140
- OSV: https://osv.dev/vulnerability/CVE-2022-33140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33140/
Summaries are generated and may contain mistakes; the official description above is the record.
