CVE-2022-33154 brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
Cross-site scripting vulnerability in the TYPO3 schema extension allows attackers to inject malicious scripts into web pages viewed by other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-33154?
CVE-2022-33154 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The schema (aka Embedding schema.org vocabulary) extension before 1.13.1 and 2.x before 2.5.1 for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2022-33154?
4 open source packages ship an affected version, including brotkrueml/schema. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
brotkrueml/schema Packagist | All versions | 1.13.1 |
brotkrueml/schema Packagist | All versions | 1.13.1 |
brotkrueml/schema Packagist | From 2.0.0 | 2.5.1 |
brotkrueml/schema Packagist | From 2.0.0 | 2.5.1 |
Products include Schema Project Schema.
How do I fix CVE-2022-33154?
Upgrade brotkrueml/schema to a fixed version for your release line: 1.13.1 or 2.5.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-33154 being exploited?
There is no known exploitation of CVE-2022-33154 in the wild and no public exploit code.
Sources
Also known as GHSA-374w-gwqr-fmxg.