# CVE-2022-33154: brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS

> Cross-site scripting vulnerability in the TYPO3 schema extension allows attackers to inject malicious scripts into web pages viewed by other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-374w-gwqr-fmxg

## What is CVE-2022-33154?

CVE-2022-33154 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The schema (aka Embedding schema.org vocabulary) extension before 1.13.1 and 2.x before 2.5.1 for TYPO3 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-33154?

4 open source packages ship an affected version, including brotkrueml/schema. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `brotkrueml/schema` | Packagist | All versions | 1.13.1 |
| `brotkrueml/schema` | Packagist | All versions | 1.13.1 |
| `brotkrueml/schema` | Packagist | From 2.0.0 | 2.5.1 |
| `brotkrueml/schema` | Packagist | From 2.0.0 | 2.5.1 |

Products: Schema Project Schema.

## How do I fix CVE-2022-33154?

Upgrade brotkrueml/schema to a fixed version for your release line: 1.13.1 or 2.5.1.

## Is CVE-2022-33154 being exploited?

There is no known exploitation of CVE-2022-33154 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33154 and fix it if it is affected.

What it is: CVE-2022-33154 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-33154 in the wild and no public exploit code.

Affected packages and fixed versions:
- brotkrueml/schema (Packagist): affected all versions; fixed in 1.13.1
- brotkrueml/schema (Packagist): affected all versions; fixed in 1.13.1
- brotkrueml/schema (Packagist): affected from 2.0.0; fixed in 2.5.1
- brotkrueml/schema (Packagist): affected from 2.0.0; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33154/ (Markdown: https://insights.sbomify.com/CVE-2022-33154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33154
- OSV: https://osv.dev/vulnerability/CVE-2022-33154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33154/
Summaries are generated and may contain mistakes; the official description above is the record.
