{"answers":{"affected":"3 open source packages ship an affected version, including brotkrueml/typo3-matomo-integration and matomo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-33156 in the wild and no public exploit code.","fix":"Upgrade brotkrueml/typo3-matomo-integration to 1.3.2 or later.","what":"CVE-2022-33156 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-33156 and fix it if it is affected.\n\nWhat it is: CVE-2022-33156 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-33156 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- brotkrueml/typo3-matomo-integration (Packagist): affected all versions; fixed in 1.3.2\n- brotkrueml/typo3-matomo-integration (Packagist): affected all versions; fixed in 1.3.2\n- matomo (Bitnami): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-33156/ (Markdown: https://insights.sbomify.com/CVE-2022-33156/index.md)","id":"CVE-2022-33156","markdown":"https://insights.sbomify.com/CVE-2022-33156/index.md","name":"CVE-2022-33156","record":{"aliases":["BIT-matomo-2022-33156","GHSA-gvxv-p9rv-gmcg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 Matomo extension","requires_auth":"none","summary":"Cross-site scripting vulnerability in the Matomo Integration extension for TYPO3 allows attackers to inject malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"integration","vendor":"matomo"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting","id":"CVE-2022-33156","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"libconnect Extension for Typo3 Vulnerable to XSS","id":"CVE-2022-33157"},"packages":[{"ecosystem":"Bitnami","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"matomo","purl":"pkg:bitnami/matomo","source":"BIT-matomo-2022-33156"},{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/typo3-matomo-integration","purl":null,"source":"GHSA-gvxv-p9rv-gmcg"},{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/typo3-matomo-integration","purl":"pkg:composer/brotkrueml/typo3-matomo-integration","source":"GHSA-gvxv-p9rv-gmcg"}],"prev":{"headline":"Cross site scripting in ameos_tarteaucitron","id":"CVE-2022-33155"},"products":["n/a"],"published":"2022-07-12","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the Matomo Integration extension for TYPO3 allows attackers to inject malicious scripts.","url":"https://insights.sbomify.com/CVE-2022-33156/"}