# CVE-2022-33156: brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting

> Cross-site scripting vulnerability in the Matomo Integration extension for TYPO3 allows attackers to inject malicious scripts.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-matomo-2022-33156, GHSA-gvxv-p9rv-gmcg

## What is CVE-2022-33156?

CVE-2022-33156 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-33156?

3 open source packages ship an affected version, including brotkrueml/typo3-matomo-integration and matomo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `brotkrueml/typo3-matomo-integration` | Packagist | All versions | 1.3.2 |
| `brotkrueml/typo3-matomo-integration` | Packagist | All versions | 1.3.2 |
| `matomo` | Bitnami | All versions | 1.3.2 |

Products: Matomo Integration.

## How do I fix CVE-2022-33156?

Upgrade brotkrueml/typo3-matomo-integration to 1.3.2 or later.

## Is CVE-2022-33156 being exploited?

There is no known exploitation of CVE-2022-33156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33156 and fix it if it is affected.

What it is: CVE-2022-33156 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-33156 in the wild and no public exploit code.

Affected packages and fixed versions:
- brotkrueml/typo3-matomo-integration (Packagist): affected all versions; fixed in 1.3.2
- brotkrueml/typo3-matomo-integration (Packagist): affected all versions; fixed in 1.3.2
- matomo (Bitnami): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33156/ (Markdown: https://insights.sbomify.com/CVE-2022-33156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33156
- OSV: https://osv.dev/vulnerability/CVE-2022-33156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33156/
Summaries are generated and may contain mistakes; the official description above is the record.
