CVE-2022-33157 libconnect Extension for Typo3 Vulnerable to XSS
Cross-site scripting vulnerability in the libconnect extension for TYPO3 allows attackers to inject malicious scripts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-33157?
CVE-2022-33157 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2022-33157?
4 open source packages ship an affected version, including subhh/libconnect. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
subhh/libconnect Packagist | All versions | 7.0.8 |
subhh/libconnect Packagist | All versions | 7.0.8 |
subhh/libconnect Packagist | From 8.0.0 | 8.1.0 |
subhh/libconnect Packagist | From 8.0.0 | 8.1.0 |
Products include Libconnect Project Libconnect.
How do I fix CVE-2022-33157?
Upgrade subhh/libconnect to a fixed version for your release line: 7.0.8 or 8.1.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-33157 being exploited?
There is no known exploitation of CVE-2022-33157 in the wild and no public exploit code.
Sources
Also known as GHSA-c8f2-5h29-8j2h.