CVE-2022-3325 Missing authorization in GitLab

Low 2.7 Published Updated

An unauthorized user can edit approval rules via the API, allowing them to bypass intended security controls in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3325?

CVE-2022-3325 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper access control in the GitLab CE/EE API affecting all versions starting from 12.8 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. Allowed for editing the approval rules via the API by an unauthorised user.

Weakness: CWE-284

Which versions are affected by CVE-2022-3325?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.8.015.2.5, 15.3.4, 15.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-3325?

Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-3325 being exploited?

There is no known exploitation of CVE-2022-3325 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3325, GHSA-339r-94ww-rwcq, UBUNTU-CVE-2022-3325.

Is CVE-2022-3325 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free