# CVE-2022-3328: snapd Race Condition vulnerability

> A race condition in snap-confine allows local attackers to escalate privileges by manipulating directory permissions during creation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** DEBIAN-CVE-2022-3328, DLA-3215-1, DSA-5292-1, GHSA-cjqf-877p-7m3f, GO-2024-2468, UBUNTU-CVE-2022-3328, USN-5753-1

## What is CVE-2022-3328?

CVE-2022-3328 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 8 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2022-3328?

3 open source packages ship an affected version, including github.com/snapcore/snapd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/snapcore/snapd` | Go | All versions | None |
| `github.com/snapcore/snapd` | Go | All versions | 2.57.6 |
| `github.com/snapcore/snapd` | Go | All versions | 2.57.6 |

Products: Canonical Snapd, Canonical Ubuntu Linux.

## How do I fix CVE-2022-3328?

Upgrade github.com/snapcore/snapd to 2.57.6 or later.

## Is CVE-2022-3328 being exploited?

There is no known exploitation of CVE-2022-3328 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-3328 with CVE-2022-41974 and CVE-2022-41973 (github_poc): https://github.com/Mr-xn/CVE-2022-3328

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2023-1523](https://insights.sbomify.com/CVE-2023-1523/): Command injection in snapd (critical 10.0)
- [CVE-2020-27352](https://insights.sbomify.com/CVE-2020-27352/): Privilege escalation in snapd (critical 9.3)
- [CVE-2019-7304](https://insights.sbomify.com/CVE-2019-7304/): Local privilege escalation via snapd socket (high 8.8)
- [CVE-2021-4120](https://insights.sbomify.com/CVE-2021-4120/): snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths (high 8.2)
- [CVE-2024-5138](https://insights.sbomify.com/CVE-2024-5138/): CVE-2024-5138: snapd snapctl auth bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3328 and fix it if it is affected.

What it is: CVE-2022-3328 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 8 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3328 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/snapcore/snapd (Go): affected all versions; no fix listed
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.57.6
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.57.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3328/ (Markdown: https://insights.sbomify.com/CVE-2022-3328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3328
- OSV: https://osv.dev/vulnerability/CVE-2022-3328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3328/
Summaries are generated and may contain mistakes; the official description above is the record.
