CVE-2022-3333 Zephyr Project Manager REST Call cross site scripting
Remote attackers can inject malicious scripts via the onanimationstart argument in the task creation REST endpoint, potentially executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2022-3333?
CVE-2022-3333 is a low-severity cross-site scripting vulnerability in Zephyr Project Manager, published on 28 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A vulnerability, which was classified as problematic, was found in Zephyr Project Manager up to 3.2.4. Affected is an unknown function of the file /v1/tasks/create/ of the component REST Call Handler. The manipulation of the argument onanimationstart leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.2.5 is able to address this issue. It is recommended to upgrade the affected component. VDB-209370 is the identifier assigned to this vulnerability.
Weakness: CWE-707
Which versions are affected by CVE-2022-3333?
It affects 1 product.
Products include Zephyr-One Zephyr Project Manager.
How do I fix CVE-2022-3333?
No fix has been published for CVE-2022-3333 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-3333 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3333 exists.
Other vulnerabilities in Zephyr Project Manager
- CVE-2022-2840 Zephyr Project Manager < 3.2.5 - Multiple Unauthenticated SQLi
- CVE-2024-37484 WordPress Zephyr Project Manager plugin <= 3.3.97 - Privilege Escalation vulnerability
- CVE-2024-7624 Zephyr Project Manager <= 3.3.101 - Authenticated (Subscriber+) Limited Privilege Escalation
- CVE-2024-38761 WordPress Zephyr Project Manager plugin <= 3.3.99 - Sensitive Data Exposure via Export File vulnerability
- CVE-2025-32526 WordPress Zephyr Project Manager plugin <= 3.3.101 - Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-2prc-g792-pf54.