# CVE-2022-3333: Zephyr Project Manager REST Call cross site scripting

> Remote attackers can inject malicious scripts via the onanimationstart argument in the task creation REST endpoint, potentially executing code in victim browsers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Sep 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-2prc-g792-pf54

## What is CVE-2022-3333?

CVE-2022-3333 is a low-severity cross-site scripting vulnerability in Zephyr Project Manager, published on 28 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in Zephyr Project Manager up to 3.2.4. Affected is an unknown function of the file /v1/tasks/create/ of the component REST Call Handler. The manipulation of the argument onanimationstart leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.2.5 is able to address this issue. It is recommended to upgrade the affected component. VDB-209370 is the identifier assigned to this vulnerability.

Weakness: CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-3333?

It affects 1 product.


Products: Zephyr-One Zephyr Project Manager.

## How do I fix CVE-2022-3333?

No fix has been published for CVE-2022-3333 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-3333 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3333 exists.

## Other vulnerabilities in Zephyr Project Manager

- [CVE-2022-2840](https://insights.sbomify.com/CVE-2022-2840/): Zephyr Project Manager < 3.2.5 - Multiple Unauthenticated SQLi (critical 9.8)
- [CVE-2024-37484](https://insights.sbomify.com/CVE-2024-37484/): WordPress Zephyr Project Manager plugin <= 3.3.97 - Privilege Escalation vulnerability (high 8.8)
- [CVE-2024-7624](https://insights.sbomify.com/CVE-2024-7624/): Zephyr Project Manager <= 3.3.101 - Authenticated (Subscriber+) Limited Privilege Escalation (high 8.1)
- [CVE-2024-38761](https://insights.sbomify.com/CVE-2024-38761/): WordPress Zephyr Project Manager plugin <= 3.3.99 - Sensitive Data Exposure via Export File vulnerability (high 7.5)
- [CVE-2025-32526](https://insights.sbomify.com/CVE-2025-32526/): WordPress Zephyr Project Manager plugin <= 3.3.101 - Cross Site Scripting (XSS) vulnerability (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3333 and fix it if it is affected.

What it is: CVE-2022-3333 is a low-severity cross-site scripting vulnerability in Zephyr Project Manager, published on 28 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3333 exists.

Affected product: Zephyr Project Manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3333/ (Markdown: https://insights.sbomify.com/CVE-2022-3333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3333
- OSV: https://osv.dev/vulnerability/CVE-2022-3333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3333/
Summaries are generated and may contain mistakes; the official description above is the record.
