CVE-2022-3358 Using a Custom Cipher with NID_undef may lead to NULL encryption
Applications using custom ciphers with NID_undef may inadvertently use NULL encryption, exposing plaintext data to attackers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3358?
CVE-2022-3358 is a high-severity vulnerability in Openssl Openssl, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenSSL supports creating a custom cipher via the legacy EVP_CIPHER_meth_new() function and associated function calls. This function was deprecated in OpenSSL 3.0 and application authors are instead encouraged to use the new provider mechanism in order to implement custom ciphers. OpenSSL versions 3.0.0 to 3.0.5 incorrectly handle legacy custom ciphers passed to the EVP_EncryptInit_ex2(), EVP_DecryptInit_ex2() and EVP_CipherInit_ex2() functions (as well as other similarly named encryption and decryption initialisation functions). Instead of using the custom cipher directly it incorrectly tries to fetch an equivalent cipher from the available providers. An equivalent cipher is found based on the NID passed to EVP_CIPHER_meth_new(). This NID is supposed to represent the unique NID for a given cipher. However it is possible for an application to incorrectly pass NID_undef as this value in the call to EVP_CIPHER_meth_new(). When NID_undef is used in this way the OpenSSL encryption/decryption initialisation function will match the NULL cipher as being equivalent and will fetch this from the available providers. This will succeed if the default provider has been loaded (or if a third party provider has been loaded that offers this cipher). Using the NULL cipher means that the plaintext is emitted as the ciphertext. Applications are only affected by this issue if they call EVP_CIPHER_meth_new() using NID_undef and subsequently use it in a call to an encryption/decryption initialisation function. Applications that only use SSL/TLS are not impacted by this issue. Fixed in OpenSSL 3.0.6 (Affected 3.0.0-3.0.5).
Weakness: CWE-476
Which versions are affected by CVE-2022-3358?
3 open source packages ship an affected version, including openssl-src. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openssl-src crates.io | From 300.0.0 | 300.0.10 |
openssl-src crates.io | From 300.0.0 | 300.0.10 |
openssl-src crates.io | From 300.0.0 | 300.0.10 |
Linux distribution packages (14)
openssl AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
openssl-devel AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
openssl-libs AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
openssl-perl AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
openssl-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
openssl-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
openssl-devel Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
openssl-libs-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
openssl-perl Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
openssl Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
openssl-debuginfo Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
openssl-debugsource Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
openssl-libs Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
openssl-libs-debuginfo Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
Products include Openssl Openssl.
How do I fix CVE-2022-3358?
Upgrade openssl-src to 300.0.10 or later.
Is CVE-2022-3358 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3358 exists.
Public exploit code: 1 Metasploit module.
Other vulnerabilities in Openssl Openssl
Sources
Also known as ALPINE-CVE-2022-3358, ALSA-2023:2523, CLEANSTART-2026-HT25779, DEBIAN-CVE-2022-3358, GHSA-4f63-89w9-3jjv, RHSA-2023:2523 and 2 more.