# CVE-2022-3358: Using a Custom Cipher with NID_undef may lead to NULL encryption

> Applications using custom ciphers with NID_undef may inadvertently use NULL encryption, exposing plaintext data to attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2022
- **Updated:** 16 Sep 2024
- **Also known as:** ALPINE-CVE-2022-3358, ALSA-2023:2523, CLEANSTART-2026-HT25779, DEBIAN-CVE-2022-3358, GHSA-4f63-89w9-3jjv, RHSA-2023:2523, RUSTSEC-2022-0059, UBUNTU-CVE-2022-3358

## What is CVE-2022-3358?

CVE-2022-3358 is a high-severity vulnerability in Openssl Openssl, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSSL supports creating a custom cipher via the legacy EVP_CIPHER_meth_new() function and associated function calls. This function was deprecated in OpenSSL 3.0 and application authors are instead encouraged to use the new provider mechanism in order to implement custom ciphers. OpenSSL versions 3.0.0 to 3.0.5 incorrectly handle legacy custom ciphers passed to the EVP_EncryptInit_ex2(), EVP_DecryptInit_ex2() and EVP_CipherInit_ex2() functions (as well as other similarly named encryption and decryption initialisation functions). Instead of using the custom cipher directly it incorrectly tries to fetch an equivalent cipher from the available providers. An equivalent cipher is found based on the NID passed to EVP_CIPHER_meth_new(). This NID is supposed to represent the unique NID for a given cipher. However it is possible for an application to incorrectly pass NID_undef as this value in the call to EVP_CIPHER_meth_new(). When NID_undef is used in this way the OpenSSL encryption/decryption initialisation function will match the NULL cipher as being equivalent and will fetch this from the available providers. This will succeed if the default provider has been loaded (or if a third party provider has been loaded that offers this cipher). Using the NULL cipher means that the plaintext is emitted as the ciphertext. Applications are only affected by this issue if they call EVP_CIPHER_meth_new() using NID_undef and subsequently use it in a call to an encryption/decryption initialisation function. Applications that only use SSL/TLS are not impacted by this issue. Fixed in OpenSSL 3.0.6 (Affected 3.0.0-3.0.5).

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2022-3358?

3 open source packages ship an affected version, including openssl-src. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.10 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.10 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.10 |
| `openssl` | AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
| `openssl-devel` | AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
| `openssl-libs` | AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
| `openssl-perl` | AlmaLinux:9 | All versions | 1:3.0.7-6.el9_2 |
| `openssl-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
| `openssl-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
| `openssl-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
| `openssl-libs-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
| `openssl-perl` | Red Hat:enterprise_linux:9::appstream | All versions | 1:3.0.7-6.el9_2 |
| `openssl` | Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
| `openssl-debuginfo` | Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
| `openssl-debugsource` | Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
| `openssl-libs` | Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |
| `openssl-libs-debuginfo` | Red Hat:enterprise_linux:9::baseos | All versions | 1:3.0.7-6.el9_2 |

Products: Openssl Openssl.

## How do I fix CVE-2022-3358?

Upgrade openssl-src to 300.0.10 or later.

## Is CVE-2022-3358 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3358 exists.

Public exploit code:

- SSL/TLS Version Detection (metasploit)

## Other vulnerabilities in Openssl Openssl

- [CVE-2009-3245](https://insights.sbomify.com/CVE-2009-3245/): Null dereference in n/a (critical 10.0)
- [CVE-2006-3738](https://insights.sbomify.com/CVE-2006-3738/): Memory corruption in n/a (critical 10.0)
- [CVE-2026-63073](https://insights.sbomify.com/CVE-2026-63073/): Untrusted Sender DN Used as Format String in CMP Response Validation (critical 9.8)
- [CVE-2016-6309](https://insights.sbomify.com/CVE-2016-6309/): Use after free in n/a (critical 9.8)
- [CVE-2016-0799](https://insights.sbomify.com/CVE-2016-0799/): Integer overflow in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3358 and fix it if it is affected.

What it is: CVE-2022-3358 is a high-severity vulnerability in Openssl Openssl, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3358 exists.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.10
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.10
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3358/ (Markdown: https://insights.sbomify.com/CVE-2022-3358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3358
- OSV: https://osv.dev/vulnerability/CVE-2022-3358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3358/
Summaries are generated and may contain mistakes; the official description above is the record.
