# CVE-2022-3366: PublishPress Capabilities < 2.5.2 - Admin+ PHP Objection Injection

> Administrators can trigger PHP object injection via imported files in multisite setups, potentially leading to code execution if gadget chains exist.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Oct 2022
- **Updated:** 6 May 2025
- **Also known as:** GHSA-x27x-7595-v3m5

## What is CVE-2022-3366?

CVE-2022-3366 is a high-severity unsafe deserialization vulnerability in Unknown PublishPress Capabilities Pro, published on 31 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by administrators, on multisite WordPress configurations. Successful exploitation in this case requires other plugins with a suitable gadget chain to be present on the site.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-3366?

It affects 1 product.


Products: Publishpress Capabilities.

## How do I fix CVE-2022-3366?

No fix has been published for CVE-2022-3366 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-3366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3366 exists.

## Other vulnerabilities in Unknown PublishPress Capabilities Pro

- [CVE-2021-25032](https://insights.sbomify.com/CVE-2021-25032/): PublishPress Capabilities < 2.3.1 - Unauthenticated Arbitrary Options Update to Blog Compromise (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3366 and fix it if it is affected.

What it is: CVE-2022-3366 is a high-severity unsafe deserialization vulnerability in Unknown PublishPress Capabilities Pro, published on 31 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3366 exists.

Affected product: Unknown PublishPress Capabilities Pro. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3366/ (Markdown: https://insights.sbomify.com/CVE-2022-3366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3366
- OSV: https://osv.dev/vulnerability/CVE-2022-3366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3366/
Summaries are generated and may contain mistakes; the official description above is the record.
