CVE-2022-33682 Disabled Hostname Verification makes Brokers, Proxies vulnerable to MITM attack

Medium 5.9 Published Updated

Disabled TLS hostname verification in Apache Pulsar clients allows man-in-the-middle attacks to intercept sensitive data and credentials.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-33682?

CVE-2022-33682 is a medium-severity vulnerability in Apache Pulsar, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TLS hostname verification cannot be enabled in the Pulsar Broker's Java Client, the Pulsar Broker's Java Admin Client, the Pulsar WebSocket Proxy's Java Client, and the Pulsar Proxy's Admin Client leaving intra-cluster connections and geo-replication connections vulnerable to man in the middle attacks, which could leak credentials, configuration data, message data, and any other data sent by these clients. The vulnerability is for both the pulsar+ssl protocol and HTTPS. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack by providing the client with a cryptographically valid certificate for an unrelated host. This issue affects Apache Pulsar Broker, Proxy, and WebSocket Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

Weakness: CWE-295

Which versions are affected by CVE-2022-33682?

16 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker and org.apache.pulsar:pulsar-proxy. It affects 1 product.

PackageAffectedFixed in
org.apache.pulsar:pulsar-broker MavenAll versions2.7.5
org.apache.pulsar:pulsar-broker MavenAll versions2.7.5
org.apache.pulsar:pulsar-broker MavenFrom 2.10.02.10.1
org.apache.pulsar:pulsar-broker MavenFrom 2.10.02.10.1
org.apache.pulsar:pulsar-broker MavenFrom 2.8.02.8.4
org.apache.pulsar:pulsar-broker MavenFrom 2.8.02.8.4
10 more packages
org.apache.pulsar:pulsar-broker MavenFrom 2.9.02.9.3
org.apache.pulsar:pulsar-broker MavenFrom 2.9.02.9.3
org.apache.pulsar:pulsar-proxy MavenAll versions2.7.5
org.apache.pulsar:pulsar-proxy MavenAll versions2.7.5
org.apache.pulsar:pulsar-proxy MavenFrom 2.10.02.10.1
org.apache.pulsar:pulsar-proxy MavenFrom 2.10.02.10.1
org.apache.pulsar:pulsar-proxy MavenFrom 2.8.02.8.4
org.apache.pulsar:pulsar-proxy MavenFrom 2.8.02.8.4
org.apache.pulsar:pulsar-proxy MavenFrom 2.9.02.9.3
org.apache.pulsar:pulsar-proxy MavenFrom 2.9.02.9.3

Products include Apache Pulsar.

How do I fix CVE-2022-33682?

Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.7.5, 2.10.1, 2.8.4 or 2.9.3.

Is CVE-2022-33682 being exploited?

There is no known exploitation of CVE-2022-33682 in the wild and no public exploit code.

Sources

Also known as GHSA-jvf3-mfxv-jcqr.

Is CVE-2022-33682 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free