# CVE-2022-33682: Disabled Hostname Verification makes Brokers, Proxies vulnerable to MITM attack

> Disabled TLS hostname verification in Apache Pulsar clients allows man-in-the-middle attacks to intercept sensitive data and credentials.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 27 May 2025
- **Also known as:** GHSA-jvf3-mfxv-jcqr

## What is CVE-2022-33682?

CVE-2022-33682 is a medium-severity vulnerability in Apache Pulsar, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TLS hostname verification cannot be enabled in the Pulsar Broker's Java Client, the Pulsar Broker's Java Admin Client, the Pulsar WebSocket Proxy's Java Client, and the Pulsar Proxy's Admin Client leaving intra-cluster connections and geo-replication connections vulnerable to man in the middle attacks, which could leak credentials, configuration data, message data, and any other data sent by these clients. The vulnerability is for both the pulsar+ssl protocol and HTTPS. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack by providing the client with a cryptographically valid certificate for an unrelated host. This issue affects Apache Pulsar Broker, Proxy, and WebSocket Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-33682?

16 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker and org.apache.pulsar:pulsar-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-broker` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar-broker` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.10.0 | 2.10.1 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.10.0 | 2.10.1 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.8.0 | 2.8.4 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.8.0 | 2.8.4 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.9.0 | 2.9.3 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.9.0 | 2.9.3 |
| `org.apache.pulsar:pulsar-proxy` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar-proxy` | Maven | All versions | 2.7.5 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.10.0 | 2.10.1 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.10.0 | 2.10.1 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.8.0 | 2.8.4 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.8.0 | 2.8.4 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.9.0 | 2.9.3 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.9.0 | 2.9.3 |

Products: Apache Pulsar.

## How do I fix CVE-2022-33682?

Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.7.5, 2.10.1, 2.8.4 or 2.9.3.

## Is CVE-2022-33682 being exploited?

There is no known exploitation of CVE-2022-33682 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33682 and fix it if it is affected.

What it is: CVE-2022-33682 is a medium-severity vulnerability in Apache Pulsar, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33682 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-broker (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar-broker (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.10.0; fixed in 2.10.1
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.10.0; fixed in 2.10.1
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.8.0; fixed in 2.8.4
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.8.0; fixed in 2.8.4
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.9.3
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.9.3
- org.apache.pulsar:pulsar-proxy (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar-proxy (Maven): affected all versions; fixed in 2.7.5
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.10.0; fixed in 2.10.1
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.10.0; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33682/ (Markdown: https://insights.sbomify.com/CVE-2022-33682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33682
- OSV: https://osv.dev/vulnerability/CVE-2022-33682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33682/
Summaries are generated and may contain mistakes; the official description above is the record.
