CVE-2022-33683 Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack
Apache Pulsar brokers and proxies fail to validate TLS certificates for internal admin clients, allowing man-in-the-middle attacks to leak sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-33683?
CVE-2022-33683 is a medium-severity vulnerability in Apache Pulsar, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.
Weakness: CWE-295
Which versions are affected by CVE-2022-33683?
16 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker and org.apache.pulsar:pulsar-proxy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar-broker Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar-broker Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar-broker Maven | From 2.10.0 | 2.10.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.10.0 | 2.10.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.8.0 | 2.8.4 |
org.apache.pulsar:pulsar-broker Maven | From 2.8.0 | 2.8.4 |
10 more packages
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.9.3 |
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.9.3 |
org.apache.pulsar:pulsar-proxy Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar-proxy Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar-proxy Maven | From 2.10.0 | 2.10.1 |
org.apache.pulsar:pulsar-proxy Maven | From 2.10.0 | 2.10.1 |
org.apache.pulsar:pulsar-proxy Maven | From 2.8.0 | 2.8.4 |
org.apache.pulsar:pulsar-proxy Maven | From 2.8.0 | 2.8.4 |
org.apache.pulsar:pulsar-proxy Maven | From 2.9.0 | 2.9.3 |
org.apache.pulsar:pulsar-proxy Maven | From 2.9.0 | 2.9.3 |
Products include Apache Pulsar.
How do I fix CVE-2022-33683?
Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.7.5, 2.10.1, 2.8.4 or 2.9.3.
Is CVE-2022-33683 being exploited?
There is no known exploitation of CVE-2022-33683 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-j3qw-g67q-7m64.