CVE-2022-33684 Apache Pulsar Disabled Certificate Validation for OAuth Client Credential Requests makes C++/Python Clients vulnerable to MITM attack

High 8.1 Published Updated

Attackers can intercept OAuth credentials via MITM due to disabled TLS validation in Pulsar C++/Python clients, enabling unauthorized cluster access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-33684?

CVE-2022-33684 is a high-severity vulnerability in Apache Pulsar, published on 4 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Pulsar C++ Client does not verify peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man in the middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow 'issuer url'. The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. The Apache Pulsar Python Client wraps the C++ client, so it is also vulnerable in the same way. This issue affects Apache Pulsar C++ Client and Python Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0 to 2.10.1; 2.6.4 and earlier. Any users running affected versions of the C++ Client or the Python Client should rotate vulnerable OAuth2.0 credentials, including client_id and client_secret. 2.7 C++ and Python Client users should upgrade to 2.7.5 and rotate vulnerable OAuth2.0 credentials. 2.8 C++ and Python Client users should upgrade to 2.8.4 and rotate vulnerable OAuth2.0 credentials. 2.9 C++ and Python Client users should upgrade to 2.9.3 and rotate vulnerable OAuth2.0 credentials. 2.10 C++ and Python Client users should upgrade to 2.10.2 and rotate vulnerable OAuth2.0 credentials. 3.0 C++ users are unaffected and 3.0 Python Client users will be unaffected when it is released. Any users running the C++ and Python Client for 2.6 or less should upgrade to one of the above patched versions.

Weakness: CWE-295

Which versions are affected by CVE-2022-33684?

9 open source packages ship an affected version, including pulsar-client. It affects 1 product.

PackageAffectedFixed in
pulsar-client PyPIAll versions2.7.5, 2.8.4, 2.9.3, 2.10.2
pulsar-client PyPIAll versions2.7.5
pulsar-client PyPIAll versions2.7.5
pulsar-client PyPIFrom 2.10.02.10.2
pulsar-client PyPIFrom 2.10.02.10.2
pulsar-client PyPIFrom 2.8.02.8.4
3 more packages
pulsar-client PyPIFrom 2.8.02.8.4
pulsar-client PyPIFrom 2.9.02.9.3
pulsar-client PyPIFrom 2.9.02.9.3

Products include Apache Pulsar.

How do I fix CVE-2022-33684?

Upgrade pulsar-client to a fixed version for your release line: 2.7.5, 2.8.4, 2.9.3 or 2.10.2.

Is CVE-2022-33684 being exploited?

There is no known exploitation of CVE-2022-33684 in the wild and no public exploit code.

Sources

Also known as GHSA-5r3h-c3r7-9w4h, PYSEC-2026-901.

Is CVE-2022-33684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free