CVE-2022-3376 Weak Password Requirements in ikus060/rdiffweb

Low 3.5 Published Updated

Weak password requirements in rdiffweb allow attackers to guess credentials and take over user accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3376?

CVE-2022-3376 is a low-severity vulnerability in ikus060/rdiffweb, published on 6 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.5.0a4.

Weakness: CWE-521

Which versions are affected by CVE-2022-3376?

3 open source packages ship an affected version, including rdiffweb. It affects 1 product.

PackageAffectedFixed in
rdiffweb PyPIAll versions2.4.11a1
rdiffweb PyPIAll versions2.5.0
rdiffweb PyPIAll versions2.5.0

Products include Ikus-Soft Rdiffweb.

How do I fix CVE-2022-3376?

Upgrade rdiffweb to a fixed version for your release line: 2.4.11a1 or 2.5.0.

Is CVE-2022-3376 being exploited?

There is no known exploitation of CVE-2022-3376 in the wild and no public exploit code.

Sources

Also known as GHSA-7wr6-fj4x-893v, PYSEC-2022-43157.

Is CVE-2022-3376 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free