# CVE-2022-3376: Weak Password Requirements in ikus060/rdiffweb

> Weak password requirements in rdiffweb allow attackers to guess credentials and take over user accounts.

- **Severity:** Low 3.5 (`CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7wr6-fj4x-893v, PYSEC-2022-43157

## What is CVE-2022-3376?

CVE-2022-3376 is a low-severity vulnerability in ikus060/rdiffweb, published on 6 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.5.0a4.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2022-3376?

3 open source packages ship an affected version, including rdiffweb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rdiffweb` | PyPI | All versions | 2.4.11a1 |
| `rdiffweb` | PyPI | All versions | 2.5.0 |
| `rdiffweb` | PyPI | All versions | 2.5.0 |

Products: Ikus-Soft Rdiffweb.

## How do I fix CVE-2022-3376?

Upgrade rdiffweb to a fixed version for your release line: 2.4.11a1 or 2.5.0.

## Is CVE-2022-3376 being exploited?

There is no known exploitation of CVE-2022-3376 in the wild and no public exploit code.

## Other vulnerabilities in ikus060/rdiffweb

- [CVE-2022-3167](https://insights.sbomify.com/CVE-2022-3167/): Improper Restriction of Rendered UI Layers or Frames in ikus060/rdiffweb (critical 10.0)
- [CVE-2022-3221](https://insights.sbomify.com/CVE-2022-3221/): Cross-Site Request Forgery (CSRF) in ikus060/rdiffweb (high 8.8)
- [CVE-2022-4724](https://insights.sbomify.com/CVE-2022-4724/): Improper Access Control in ikus060/rdiffweb (high 8.4)
- [CVE-2022-3389](https://insights.sbomify.com/CVE-2022-3389/): Path Traversal in ikus060/rdiffweb (high 8.2)
- [CVE-2022-3371](https://insights.sbomify.com/CVE-2022-3371/): rdiffweb's lack of token name length limit can result in DoS or memory corruption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3376 and fix it if it is affected.

What it is: CVE-2022-3376 is a low-severity vulnerability in ikus060/rdiffweb, published on 6 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3376 in the wild and no public exploit code.

Affected packages and fixed versions:
- rdiffweb (PyPI): affected all versions; fixed in 2.4.11a1
- rdiffweb (PyPI): affected all versions; fixed in 2.5.0
- rdiffweb (PyPI): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3376/ (Markdown: https://insights.sbomify.com/CVE-2022-3376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3376
- OSV: https://osv.dev/vulnerability/CVE-2022-3376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3376/
Summaries are generated and may contain mistakes; the official description above is the record.
