CVE-2022-33891 Apache Spark Command Injection
Attackers can execute arbitrary shell commands via Spark UI impersonation when ACLs are enabled, requiring an upgrade to secure the cluster.
- Exploited in the wild
- Since 7 Mar 2023
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-33891?
CVE-2022-33891 is a high-severity command injection vulnerability in Apache Spark, published on 18 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.
Weakness: CWE-78
Which versions are affected by CVE-2022-33891?
10 open source packages ship an affected version, including org.apache.spark:spark-parent_2.12, spark and pyspark. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.spark:spark-parent_2.12 Maven | All versions to 3.0.3 | None |
org.apache.spark:spark-parent_2.12 Maven | All versions to 3.0.3 | None |
org.apache.spark:spark-parent_2.12 Maven | From 3.1.1 | 3.2.2 |
org.apache.spark:spark-parent_2.12 Maven | From 3.1.1 | 3.2.2 |
spark Bitnami | All versions | 3.0.4, 3.1.3, 3.2.2 |
pyspark PyPI | All versions | 3.1.3, 3.2.2 |
4 more packages
pyspark PyPI | All versions | 3.1.3 |
pyspark PyPI | All versions | 3.1.3 |
pyspark PyPI | From 3.2.0 | 3.2.2 |
pyspark PyPI | From 3.2.0 | 3.2.2 |
Products include Apache Spark.
How do I fix CVE-2022-33891?
Upgrade org.apache.spark:spark-parent_2.12 to 3.2.2 or later. US federal agencies must fix it by 28 Mar 2023.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-33891 being exploited?
Yes. Attackers have exploited CVE-2022-33891 in the wild since at least 7 Mar 2023.
Public exploit code: 1 Metasploit module, 1 Nuclei template and 10 proofs of concept on GitHub.
Other vulnerabilities in Apache Spark
Sources
Also known as BIT-spark-2022-33891, GHSA-4x9r-j582-cgr8, PYSEC-2022-236.