# CVE-2022-33891: Apache Spark Command Injection

> Attackers can execute arbitrary shell commands via Spark UI impersonation when ACLs are enabled, requiring an upgrade to secure the cluster.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 7 Mar 2023 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2022
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-spark-2022-33891, GHSA-4x9r-j582-cgr8, PYSEC-2022-236

## What is CVE-2022-33891?

CVE-2022-33891 is a high-severity command injection vulnerability in Apache Spark, published on 18 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-33891?

10 open source packages ship an affected version, including org.apache.spark:spark-parent_2.12, spark and pyspark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-parent_2.12` | Maven | All versions to 3.0.3 | None |
| `org.apache.spark:spark-parent_2.12` | Maven | All versions to 3.0.3 | None |
| `org.apache.spark:spark-parent_2.12` | Maven | From 3.1.1 | 3.2.2 |
| `org.apache.spark:spark-parent_2.12` | Maven | From 3.1.1 | 3.2.2 |
| `spark` | Bitnami | All versions | 3.0.4, 3.1.3, 3.2.2 |
| `pyspark` | PyPI | All versions | 3.1.3, 3.2.2 |
| `pyspark` | PyPI | All versions | 3.1.3 |
| `pyspark` | PyPI | All versions | 3.1.3 |
| `pyspark` | PyPI | From 3.2.0 | 3.2.2 |
| `pyspark` | PyPI | From 3.2.0 | 3.2.2 |

Products: Apache Spark.

## How do I fix CVE-2022-33891?

Upgrade org.apache.spark:spark-parent_2.12 to 3.2.2 or later. US federal agencies must fix it by 28 Mar 2023.

## Is CVE-2022-33891 being exploited?

Yes. Attackers have exploited CVE-2022-33891 in the wild since at least 7 Mar 2023.

Public exploit code:

- Apache Spark Shell Command Injection Vulnerability (github_poc): https://github.com/HuskyHacks/cve-2022-33891
- cve-2022-33891-poc (github_poc): https://github.com/W01fh4cker/cve-2022-33891
- 「💥」CVE-2022-33891 - Apache Spark Command Injection (github_poc): https://github.com/AmoloHT/CVE-2022-33891
- https://github.com/AkbarTrilaksana/cve-2022-33891 (github_poc): https://github.com/AkbarTrilaksana/cve-2022-33891
- CVE-2022-33891 Exploit For Apache Spark (github_poc): https://github.com/DrLinuxOfficial/CVE-2022-33891
- Apache Spark RCE - CVE-2022-33891 (github_poc): https://github.com/Vulnmachines/Apache-spark-CVE-2022-33891

## Other vulnerabilities in Apache Spark

- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)
- [CVE-2023-32007](https://insights.sbomify.com/CVE-2023-32007/): Apache Spark: Shell command injection via Spark UI (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33891 and fix it if it is affected.

What it is: CVE-2022-33891 is a high-severity command injection vulnerability in Apache Spark, published on 18 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2022-33891 in the wild since at least 7 Mar 2023.

Affected packages and fixed versions:
- org.apache.spark:spark-parent_2.12 (Maven): affected all versions up to 3.0.3; no fix listed
- org.apache.spark:spark-parent_2.12 (Maven): affected all versions up to 3.0.3; no fix listed
- org.apache.spark:spark-parent_2.12 (Maven): affected from 3.1.1; fixed in 3.2.2
- org.apache.spark:spark-parent_2.12 (Maven): affected from 3.1.1; fixed in 3.2.2
- spark (Bitnami): affected all versions; fixed in 3.0.4, 3.1.3, 3.2.2
- pyspark (PyPI): affected all versions; fixed in 3.1.3, 3.2.2
- pyspark (PyPI): affected all versions; fixed in 3.1.3
- pyspark (PyPI): affected all versions; fixed in 3.1.3
- pyspark (PyPI): affected from 3.2.0; fixed in 3.2.2
- pyspark (PyPI): affected from 3.2.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33891/ (Markdown: https://insights.sbomify.com/CVE-2022-33891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33891
- OSV: https://osv.dev/vulnerability/CVE-2022-33891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33891/
Summaries are generated and may contain mistakes; the official description above is the record.
