# CVE-2022-33970: WordPress Shortcode Addons plugin <= 3.1.2 - Authenticated WordPress Options Change vulnerability

> Authenticated users can modify WordPress options due to missing authorization checks in the Shortcode Addons plugin.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Jul 2022
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-5cvc-6x68-h8qf

## What is CVE-2022-33970?

CVE-2022-33970 is a high-severity missing authorization vulnerability in Biplob018 Shortcode Addons (WordPress plugin), published on 27 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Authenticated WordPress Options Change vulnerability in Biplob018 Shortcode Addons plugin <= 3.1.2 at WordPress.

Weakness: CWE-264

## Which versions are affected by CVE-2022-33970?

It affects 1 product.


Products: Oxilab Shortcode Addons.

## How do I fix CVE-2022-33970?

No fix has been published for CVE-2022-33970 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-33970 being exploited?

There is no known exploitation of CVE-2022-33970 in the wild and no public exploit code.

## Other vulnerabilities in Biplob018 Shortcode Addons (WordPress plugin)

- [CVE-2022-34487](https://insights.sbomify.com/CVE-2022-34487/): WordPress Shortcode Addons plugin <= 3.0.2 - Unauthenticated Arbitrary Option Update vulnerability (critical 9.8)
- [CVE-2024-37121](https://insights.sbomify.com/CVE-2024-37121/): WordPress Shortcode Addons plugin <= 3.2.5 - Cross Site Scripting (XSS) vulnerability (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33970 and fix it if it is affected.

What it is: CVE-2022-33970 is a high-severity missing authorization vulnerability in Biplob018 Shortcode Addons (WordPress plugin), published on 27 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33970 in the wild and no public exploit code.

Affected product: Biplob018 Shortcode Addons (WordPress plugin). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33970/ (Markdown: https://insights.sbomify.com/CVE-2022-33970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33970
- OSV: https://osv.dev/vulnerability/CVE-2022-33970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33970/
Summaries are generated and may contain mistakes; the official description above is the record.
