{"answers":{"affected":"3 open source packages ship an affected version, including untangle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-33977 in the wild and no public exploit code.","fix":"Upgrade untangle to 1.2.1 or later.","what":"CVE-2022-33977 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-33977 and fix it if it is affected.\n\nWhat it is: CVE-2022-33977 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-33977 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-33977/ (Markdown: https://insights.sbomify.com/CVE-2022-33977/index.md)","id":"CVE-2022-33977","markdown":"https://insights.sbomify.com/CVE-2022-33977/index.md","name":"CVE-2022-33977","record":{"aliases":["DEBIAN-CVE-2022-33977","GHSA-7xr3-6ggc-wc9p","PYSEC-2022-243"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python XML library","requires_auth":"none","summary":"A remote attacker can cause a denial-of-service condition in applications using the untangle Python library by exploiting improper restriction of recursive entity references in XML DTDs.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"untangle","vendor":"untangle_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts recursive entity references in DTDs. By exploiting this vulnerability, a remote unauthenticated attacker may cause a denial-of-service (DoS) condition on the server where the product is running.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"untangle vulnerable to XML Entity Expansion","id":"CVE-2022-33977","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"WordPress FontMeister plugin \u003c= 1.08 - Reflected Cross-Site Scripting (XSS) vulnerability","id":"CVE-2022-33978"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":null,"source":"GHSA-7xr3-6ggc-wc9p"},{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":"pkg:pypi/untangle","source":"GHSA-7xr3-6ggc-wc9p"},{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":"pkg:pypi/untangle","source":"PYSEC-2022-243"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-33976"},"products":["untangle"],"published":"2022-07-26","related":[{"cvss_score":7.5,"headline":"untangle vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2022-31471","kev_date_added":null,"published":"2022-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Christian Stefanescu"]},"summary":"A remote attacker can cause a denial-of-service condition in applications using the untangle Python library by exploiting improper restriction of recursive entity references in XML DTDs.","url":"https://insights.sbomify.com/CVE-2022-33977/"}