# CVE-2022-33977: untangle vulnerable to XML Entity Expansion

> A remote attacker can cause a denial-of-service condition in applications using the untangle Python library by exploiting improper restriction of recursive entity references in XML DTDs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-33977, GHSA-7xr3-6ggc-wc9p, PYSEC-2022-243

## What is CVE-2022-33977?

CVE-2022-33977 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts recursive entity references in DTDs. By exploiting this vulnerability, a remote unauthenticated attacker may cause a denial-of-service (DoS) condition on the server where the product is running.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2022-33977?

3 open source packages ship an affected version, including untangle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `untangle` | PyPI | All versions | 1.2.1 |
| `untangle` | PyPI | All versions | 1.2.1 |
| `untangle` | PyPI | All versions | 1.2.1 |

Products: Untangle Project Untangle.

## How do I fix CVE-2022-33977?

Upgrade untangle to 1.2.1 or later.

## Is CVE-2022-33977 being exploited?

There is no known exploitation of CVE-2022-33977 in the wild and no public exploit code.

## Other vulnerabilities in Christian Stefanescu untangle

- [CVE-2022-31471](https://insights.sbomify.com/CVE-2022-31471/): untangle vulnerable to Improper Restriction of XML External Entity Reference (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-33977 and fix it if it is affected.

What it is: CVE-2022-33977 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-33977 in the wild and no public exploit code.

Affected packages and fixed versions:
- untangle (PyPI): affected all versions; fixed in 1.2.1
- untangle (PyPI): affected all versions; fixed in 1.2.1
- untangle (PyPI): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-33977/ (Markdown: https://insights.sbomify.com/CVE-2022-33977/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-33977
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-33977
- OSV: https://osv.dev/vulnerability/CVE-2022-33977

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-33977/
Summaries are generated and may contain mistakes; the official description above is the record.
