CVE-2022-33980 Apache Commons Configuration insecure interpolation defaults
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-33980?
CVE-2022-33980 is a critical vulnerability in Debian Debian Linux, published on 6 Jul 2022.
Official description
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
Which versions are affected by CVE-2022-33980?
2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.commons:commons-configuration2 Maven | From 2.4 | 2.8.0 |
org.apache.commons:commons-configuration2 Maven | From 2.4 | 2.8.0 |
Linux distribution packages (1)
apache-commons-configuration2 openSUSE:Tumbleweed | All versions | 2.9.0-1.1 |
Products include Apache Commons Configuration, Debian Debian Linux, Netapp Snapcenter.
How do I fix CVE-2022-33980?
Upgrade org.apache.commons:commons-configuration2 to 2.8.0 or later.
Is CVE-2022-33980 being exploited?
There is no known exploitation of CVE-2022-33980 in the wild and no public exploit code.
Public exploit code: 5 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
- CVE-2020-1953 Remote code execution in Apache Commons Configuration
- CVE-2024-29131 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()
- CVE-2025-46392 Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x
- CVE-2024-29133 Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree
- CVE-2026-45205 Apache Commons Configuration: StackOverflowError for YAML input with cycles
Sources
Also known as DEBIAN-CVE-2022-33980, DSA-5290-1, GHSA-xj57-8qj4-c4m6, UBUNTU-CVE-2022-33980, openSUSE-SU-2024:13259-1.