{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-33980 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-configuration2 to 2.8.0 or later.","what":"CVE-2022-33980 is a critical vulnerability in Debian Debian Linux, published on 6 Jul 2022."},"fix_prompt":"Check this codebase for CVE-2022-33980 and fix it if it is affected.\n\nWhat it is: CVE-2022-33980 is a critical vulnerability in Debian Debian Linux, published on 6 Jul 2022. \nExploitation: There is no known exploitation of CVE-2022-33980 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.4; fixed in 2.8.0\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.4; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-33980/ (Markdown: https://insights.sbomify.com/CVE-2022-33980/index.md)","id":"CVE-2022-33980","markdown":"https://insights.sbomify.com/CVE-2022-33980/index.md","name":"CVE-2022-33980","record":{"aliases":["DEBIAN-CVE-2022-33980","DSA-5290-1","GHSA-xj57-8qj4-c4m6","UBUNTU-CVE-2022-33980","openSUSE-SU-2024:13259-1"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"commons_configuration","vendor":"apache"},{"product":"debian_linux","vendor":"debian"},{"product":"snapcenter","vendor":"netapp"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is \"${prefix:name}\", where \"prefix\" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - \"script\" - execute expressions using the JVM script execution engine (javax.script) - \"dns\" - resolve dns records - \"url\" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.","ecosystems":["Maven","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2022-07-08","github_poc":5,"max_poc_stars":43,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-07-08T09:25:42Z","kind":"github_poc","ref":"https://github.com/tangxiaofeng7/CVE-2022-33980-Apache-Commons-Configuration-RCE","stars":43,"title":"CVE-2022-33980 Apache Commons Configuration 远程命令执行漏洞"},{"date":"2022-08-10T03:21:19Z","kind":"github_poc","ref":"https://github.com/HKirito/CVE-2022-33980","stars":30,"title":"CVE"},{"date":"2022-10-17T21:39:03Z","kind":"github_poc","ref":"https://github.com/sammwyy/CVE-2022-33980-POC","stars":5,"title":"POC for CVE-2022-33980 (Apache Commons Configuration RCE vulnerability)"},{"date":"2023-07-18T17:55:58Z","kind":"github_poc","ref":"https://github.com/joseluisinigo/riskootext4shell","stars":1,"title":"text4shell script for text coomons \u003c =1.10 CVE-2022-33980"},{"date":"2022-12-22T10:16:08Z","kind":"github_poc","ref":"https://github.com/P0lar1ght/CVE-2022-33980-POC","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache Commons Configuration insecure interpolation defaults","id":"CVE-2022-33980","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux","netapp:snapcenter"],"type":null,"year":"2022"},"n_packages":3,"n_references":5,"next":{"headline":"Use after free in n/a","id":"CVE-2022-33981"},"packages":[{"ecosystem":"Maven","fixed":["2.8.0"],"introduced":["2.4"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":null,"source":"GHSA-xj57-8qj4-c4m6"},{"ecosystem":"Maven","fixed":["2.8.0"],"introduced":["2.4"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":"pkg:maven/org.apache.commons/commons-configuration2","source":"GHSA-xj57-8qj4-c4m6"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.9.0-1.1"],"introduced":["0"],"last_affected":[],"package":"apache-commons-configuration2","purl":"pkg:rpm/opensuse/apache-commons-configuration2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13259-1"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-33979"},"products":["Apache Commons Configuration"],"published":"2022-07-06","related":[{"cvss_score":10,"headline":"Remote code execution in Apache Commons Configuration","id":"CVE-2020-1953","kev_date_added":null,"published":"2020-03-13"},{"cvss_score":7.3,"headline":"Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()","id":"CVE-2024-29131","kev_date_added":null,"published":"2024-03-21"},{"cvss_score":6.5,"headline":"Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x","id":"CVE-2025-46392","kev_date_added":null,"published":"2025-05-09"},{"cvss_score":5.4,"headline":"Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree","id":"CVE-2024-29133","kev_date_added":null,"published":"2024-03-21"},{"cvss_score":5.3,"headline":"Apache Commons Configuration: StackOverflowError for YAML input with cycles","id":"CVE-2026-45205","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-33980/"}