CVE-2022-33987 Got allows a redirect to a UNIX socket
The got HTTP client library allows Server-Side Request Forgery by redirecting requests to UNIX sockets, potentially exposing local services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-33987?
CVE-2022-33987 is a medium-severity server-side request forgery vulnerability in n/a, published on 18 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The got package before 12.1.0 (also fixed in 11.8.5) for Node.js allows a redirect to a UNIX socket.
Which versions are affected by CVE-2022-33987?
4 open source packages ship an affected version, including got. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
got npm | All versions | 11.8.5 |
got npm | All versions | 11.8.5 |
got npm | From 12.0.0 | 12.1.0 |
got npm | From 12.0.0 | 12.1.0 |
Products include Got Project Got.
How do I fix CVE-2022-33987?
Upgrade got to a fixed version for your release line: 11.8.5 or 12.1.0.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2022-33987 being exploited?
There is no known exploitation of CVE-2022-33987 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-AM42302, CLEANSTART-2026-UC56558, CLSA-2026-1771891819, CLSA-2026-1773188113, CLSA-2026-1773706626, CLSA-2026-1784596291 and 9 more.