{"answers":{"affected":"1 open source package ship an affected version, including etcd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34038 in the wild and no public exploit code.","fix":"Upgrade etcd to 3.5.5 or later.","what":"CVE-2022-34038 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-34038 and fix it if it is affected.\n\nWhat it is: CVE-2022-34038 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-34038 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- etcd (Bitnami): affected from 3.5.4; fixed in 3.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34038/ (Markdown: https://insights.sbomify.com/CVE-2022-34038/index.md)","id":"CVE-2022-34038","markdown":"https://insights.sbomify.com/CVE-2022-34038/index.md","name":"CVE-2022-34038","record":{"aliases":["BIT-etcd-2022-34038","DEBIAN-CVE-2022-34038"],"analysis":{"component_type":"server_software","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"etcd distributed key-value store","requires_auth":"none","summary":"Remote attackers can cause a denial of service in etcd via a flaw in the PageWriter write function, though the vendor disputes this classification.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"etcd","vendor":"etcd"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Etcd v3.5.4 allows remote attackers to cause a denial of service via function PageWriter.write in pagewriter.go. NOTE: the vendor's position is that this is not a vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-34038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":5,"next":{"headline":"SQL injection in n/a","id":"CVE-2022-34042"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.5"],"introduced":["3.5.4"],"last_affected":[],"package":"etcd","purl":"pkg:bitnami/etcd","source":"BIT-etcd-2022-34038"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-34037"},"products":["n/a"],"published":"2023-08-22","related":[{"cvss_score":9.8,"headline":"Etcd-io Improper Authentication vulnerability","id":"CVE-2021-28235","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":8.8,"headline":"etcd: Authorization bypasses in multiple APIs","id":"CVE-2026-33413","kev_date_added":null,"published":"2026-03-26"},{"cvss_score":6.8,"headline":"go.etcd.io/etcd Authentication Bypass","id":"CVE-2018-16886","kev_date_added":null,"published":"2019-01-14"},{"cvss_score":6.5,"headline":"etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation","id":"CVE-2026-59818","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":6.5,"headline":"Improper Input Validation in etcd","id":"CVE-2020-15106","kev_date_added":null,"published":"2020-08-05"},{"cvss_score":6.5,"headline":"Improper Input Validation in etcd","id":"CVE-2020-15112","kev_date_added":null,"published":"2020-08-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in etcd via a flaw in the PageWriter write function, though the vendor disputes this classification.","url":"https://insights.sbomify.com/CVE-2022-34038/"}